CreateViaTransform Method


Creates a new curve loop as a transformed copy of the input curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public static CurveLoop CreateViaTransform(
	CurveLoop curveLoop,
	Transform transform
)
Visual Basic
Public Shared Function CreateViaTransform ( _
	curveLoop As CurveLoop, _
	transform As Transform _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaTransform(
	CurveLoop^ curveLoop, 
	Transform^ transform
)

Parameters

curveLoop
Type: Autodesk.Revit.DBCurveLoop
The input curve loop.
transform
Type: Autodesk.Revit.DBTransform
The transformation.

Return Value

The new curve loop.

Remarks

The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException transform is not conformal. -or- transform has a scale that is negative or zero.

See Also