CreateViaTransform Method


Curve Loop Create Via Transform Method

Creates a new curve loop as a transformed copy of the input curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveLoop CreateViaTransform(
	CurveLoop curveLoop,
	Transform transform
)

Parameters

curveLoop CurveLoop
The input curve loop.
transform Transform
The transformation.

Return Value

CurveLoop
The new curve loop.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException transform is not conformal. -or- transform has a scale that is negative or zero.
Remarks
The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).
See Also