GetReferencedViewId Method


Gets the id of the view referenced by a reference view (such as a reference section or reference callout).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static ElementId GetReferencedViewId(
	Document document,
	ElementId referenceId
)
Visual Basic
Public Shared Function GetReferencedViewId ( _
	document As Document, _
	referenceId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetReferencedViewId(
	Document^ document, 
	ElementId^ referenceId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document containing the elements.
referenceId
Type: Autodesk.Revit.DBElementId
The reference view that will be changed to refer to a different View.

Return Value

The id of the referenced view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException referenceId is not a valid reference view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also