GetReferencedViewId Method


Referenceable View Utils Get Referenced View Id Method

Gets the id of the view referenced by a reference view (such as a reference section or reference callout).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId GetReferencedViewId(
	Document document,
	ElementId referenceId
)

Parameters

document Document
The document containing the elements.
referenceId ElementId
The reference view that will be changed to refer to a different View.

Return Value

ElementId
The id of the referenced view.
Exceptions
Exception Condition
ArgumentException referenceId is not a valid reference view.
ArgumentNullException A non-optional argument was null
See Also