For shape driven rebar returns all possible RebarConstraints that will constrain RebarConstrainedHandle to the provided reference.
For free form rebar will return an empty lists.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- handle
- Type: Autodesk.Revit.DB.StructureRebarConstrainedHandle
The RebarConstrainedHandle for which constraint candidates are sought.
- reference
- Type: Autodesk.Revit.DBReference
The reference you want to constrain to.
Return Value
A collection of RebarConstraintsRemarks
Will throw exception if the provided reference cannot be used to constrain the provided rebar handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | reference is not from a valid RebarConstraint target element. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |