Rebar |
For shape driven rebar returns all possible RebarConstraints that will constrain RebarConstrainedHandle to the provided reference.
For free form rebar will return an empty list.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IList<RebarConstraint> GetConstraintCandidatesForHandle(
RebarConstrainedHandle handle,
Reference reference
)
Parameters
- handle RebarConstrainedHandle
- The RebarConstrainedHandle for which constraint candidates are sought.
- reference Reference
- The reference you want to constrain to. It can be a reference to any host in the model or any bar from any host.
Return Value
IList RebarConstraintA collection of RebarConstraints

Exception | Condition |
---|---|
ArgumentException | reference is not from a valid RebarConstraint target element. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |

Will throw exception if the provided reference cannot be used to constrain the provided rebar handle.