SetSketchedLandingBoundaryAndPath Method


Sets the boundary and path curves of the sketched landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void SetSketchedLandingBoundaryAndPath(
	Document document,
	CurveLoop boundaryCurveLoop,
	CurveLoop pathCurveLoop
)
Visual Basic
Public Sub SetSketchedLandingBoundaryAndPath ( _
	document As Document, _
	boundaryCurveLoop As CurveLoop, _
	pathCurveLoop As CurveLoop _
)
Visual C++
public:
void SetSketchedLandingBoundaryAndPath(
	Document^ document, 
	CurveLoop^ boundaryCurveLoop, 
	CurveLoop^ pathCurveLoop
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document that owns the landing.
boundaryCurveLoop
Type: Autodesk.Revit.DBCurveLoop
The closed boundary curves of the landing.
pathCurveLoop
Type: Autodesk.Revit.DBCurveLoop
The path curves of the landing, can be an empty CurveLoop.

Remarks

This should be run from within an open transaction.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The boundaryCurveLoop is not closed. -or- The input boundaryCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The input pathCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- Failed to create curve element by the boundaryCurveLoop or pathCurveLoop.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also