Stairs |
Sets the boundary and path curves of the sketched landing.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetSketchedLandingBoundaryAndPath(
Document document,
CurveLoop boundaryCurveLoop,
CurveLoop pathCurveLoop
)
Parameters

Exception | Condition |
---|---|
ArgumentException | The boundaryCurveLoop is not closed. -or- The input boundaryCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The input pathCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- Failed to create curve element by the boundaryCurveLoop or pathCurveLoop. |
ArgumentNullException | A non-optional argument was null |

This should be run from within an open transaction.