RemoveSize Method


Erases the existing MEPSize. For cable tray, the nominal diameter is used in MEPSize.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void RemoveSize(
	MEPSize sizeInfo
)
Visual Basic
Public Sub RemoveSize ( _
	sizeInfo As MEPSize _
)
Visual C++
public:
void RemoveSize(
	MEPSize^ sizeInfo
)

Parameters

sizeInfo
Type: Autodesk.Revit.DBMEPSize
The MEPSize to be removed..

Remarks

Does nothing if there is no existing MEPSize with the specified nominal diameter.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Throws if the function is called during iterating the size set.

See Also