Gets the curve loop corresponding to the hole in the wall made by the instance.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pADoc
- Type: Autodesk.Revit.DBDocument
The document.
- pVWall
- Type: Autodesk.Revit.DBWall
The host wall.
- pFamInst
- Type: Autodesk.Revit.DBFamilyInstance
The hosted instance.
- pCutDir
- Type: Autodesk.Revit.DBXYZ%
The direction of the hole relative to the location of the curve loop.
Return Value
The opening in the wall.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |