Exporter |
Gets the curve loop corresponding to the hole in the wall made by the instance.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static CurveLoop GetInstanceCutoutFromWall(
Document pADoc,
Wall pVWall,
FamilyInstance pFamInst,
out XYZ pCutDir
)
Parameters
- pADoc Document
- The document.
- pVWall Wall
- The host wall.
- pFamInst FamilyInstance
- The hosted instance.
- pCutDir XYZ
- The direction of the hole relative to the location of the curve loop.
Return Value
CurveLoopThe opening in the wall.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |