Sets the DirectShapeType for the DirectShape element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- typeId
- Type: Autodesk.Revit.DBElementId
The ID of the type corresponding to this DirectShape element. May only be set once.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | typeId is not a valid Element identifier. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |