SetTypeId Method


Direct Shape Set Type Id Method

Sets the DirectShapeType for the DirectShape element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetTypeId(
	ElementId typeId
)

Parameters

typeId ElementId
The ID of the type corresponding to this DirectShape element. May only be set once.
Exceptions
Exception Condition
ArgumentException typeId is not a valid Element identifier.
ArgumentNullException A non-optional argument was null
See Also