NewSpaceTag Method


Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SpaceTag NewSpaceTag(
	Space space,
	UV point,
	View view
)
Visual Basic
Public Function NewSpaceTag ( _
	space As Space, _
	point As UV, _
	view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
	Space^ space, 
	UV^ point, 
	View^ view
)

Parameters

space
Type: Autodesk.Revit.DB.MechanicalSpace
The Space which the tag refers.
point
Type: Autodesk.Revit.DBUV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.DBView
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise a null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the space does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the view does not exist in the given document.

See Also