Returns a normal unit vector at the given index.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idx
- Type: SystemInt32
A zero-based index. It must be consistent with the DistributionOfNormals.
Return Value
XYZ value representing a normal unit vector.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value is not a valid index of a normal of the mesh. A valid value is not negative and is smaller than the number of normals in the mesh. |