GetNormal Method


Mesh Get Normal Method

Returns a normal unit vector at the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ GetNormal(
	int idx
)

Parameters

idx Int32
A zero-based index. It must be consistent with the DistributionOfNormals.

Return Value

XYZ
XYZ value representing a normal unit vector.
Exceptions
Exception Condition
ArgumentException The given value is not a valid index of a normal of the mesh. A valid value is not negative and is smaller than the number of normals in the mesh.
See Also