SplitStraight Method (XYZ)


Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public ElementId SplitStraight(
	XYZ position
)
Visual Basic
Public Function SplitStraight ( _
	position As XYZ _
) As ElementId
Visual C++
public:
ElementId^ SplitStraight(
	XYZ^ position
)

Parameters

position
Type: Autodesk.Revit.DBXYZ
The position to split in the straight.

Return Value

Returns the element identifier of the new straight.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The position is not on the straight.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The part is not a straight.

See Also