SplitStraight Method (XYZ)


Fabrication Part Split Straight(XYZ) Method

Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SplitStraight(
	XYZ position
)

Parameters

position XYZ
The position to split in the straight.

Return Value

ElementId
Returns the element identifier of the new straight.
Exceptions
Exception Condition
ArgumentException The position is not on the straight.
ArgumentNullException A non-optional argument was null
InvalidOperationException The part is not a straight.
See Also