Attaches the hanger rod to another bearer hanger.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hangerId
- Type: Autodesk.Revit.DBElementId
Identifier of the bearer hanger to which the rod attaches.
- rodIndex
- Type: SystemInt32
The index of the rod.
- position
- Type: Autodesk.Revit.DBXYZ
The position of the rod end. It should be on bearer centerline.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The hanger is not a bearer hanger. -or- The point is not on hanger bearer centerline. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |