AttachToHanger Method


Fabrication Rod Info Attach To Hanger Method

Attaches the hanger rod to another bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AttachToHanger(
	ElementId hangerId,
	int rodIndex,
	XYZ position
)

Parameters

hangerId ElementId
Identifier of the bearer hanger to which the rod attaches.
rodIndex Int32
The index of the rod.
position XYZ
The position of the rod end. It should be on bearer centerline.
Exceptions
Exception Condition
ArgumentException The hanger is not a bearer hanger. -or- The point is not on hanger bearer centerline.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
See Also