Moves Adaptive Component Instance by the specified transformation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- famInst
- Type: Autodesk.Revit.DBFamilyInstance
The FamilyInstance
- trf
- Type: Autodesk.Revit.DBTransform
The Transformation
- unHost
- Type: SystemBoolean
True if the move should disassociate the Point Element Refs from their hosts. False if the Point Element Refs remain hosted.
Remarks
This method will attempt a rigid body motion of all the individual references and hence the instance itself. However if unHost parameter is 'false' and any of the instance's references are hosted to any geometry, then those references will move within the constraints. The instance then adapts to where its references are moved to.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | trf is not a rigid body transformation. |
Autodesk.Revit.ExceptionsInvalidOperationException | Unable to move the adaptive component instance. |