MoveAdaptiveComponentInstance Method


Adaptive Component Instance Utils Move Adaptive Component Instance Method

Moves Adaptive Component Instance by the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void MoveAdaptiveComponentInstance(
	FamilyInstance famInst,
	Transform trf,
	bool unHost
)

Parameters

famInst FamilyInstance
The FamilyInstance
trf Transform
The Transformation
unHost Boolean
True if the move should disassociate the Point Element Refs from their hosts. False if the Point Element Refs remain hosted.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException trf is not a rigid body transformation.
InvalidOperationException Unable to move the adaptive component instance.
Remarks
This method will attempt a rigid body motion of all the individual references and hence the instance itself. However if unHost parameter is 'false' and any of the instance's references are hosted to any geometry, then those references will move within the constraints. The instance then adapts to where its references are moved to.
See Also