Add a definition to be reused by instances. A definition is a collection of geometry objects.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: SystemString
ID of the definition to be added. Must be unique.
- GNodes
- Type: System.Collections.GenericIListGeometryObject
Definition as a list of Geometry objects
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |