AddDefinition Method (String, IList(GeometryObject))


Direct Shape Library Add Definition(String, IList Geometry Object ) Method

Add a definition to be reused by instances. A definition is a collection of geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddDefinition(
	string id,
	IList<GeometryObject> GNodes
)

Parameters

id String
ID of the definition to be added. Must be unique.
GNodes IList GeometryObject
Definition as a list of Geometry objects
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also