Adds a new flexible duct into the document, using two connector, and duct type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- connector1
- Type: Autodesk.Revit.DBConnector
The first connector to be connected to the duct.
- connector2
- Type: Autodesk.Revit.DBConnector
The second connector to be connected to the duct.
- ductType
- Type: Autodesk.Revit.DB.MechanicalFlexDuctType
The type of the flexible duct.
Return Value
If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.Remarks
If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument connector1 or connector2 is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails. |
Autodesk.Revit.ExceptionsArgumentException | Thrown if the flexible duct type does not exist in the given document. |