Document New |
Adds a new flexible duct into the document, using two connector, and duct type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FlexDuct NewFlexDuct(
Connector connector1,
Connector connector2,
FlexDuctType ductType
)
Parameters
- connector1 Connector
- The first connector to be connected to the duct.
- connector2 Connector
- The second connector to be connected to the duct.
- ductType FlexDuctType
- The type of the flexible duct.
Return Value
FlexDuctIf creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument connector1 or connector2 is . |
InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails. |
ArgumentException | Thrown if the flexible duct type does not exist in the given document. |

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.