AreCurveReferencesConnected Method


This checks if the references represent a connected set of curves as required by the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static bool AreCurveReferencesConnected(
	Document document,
	IList<Reference> curveReferences
)
Visual Basic
Public Shared Function AreCurveReferencesConnected ( _
	document As Document, _
	curveReferences As IList(Of Reference) _
) As Boolean
Visual C++
public:
static bool AreCurveReferencesConnected(
	Document^ document, 
	IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
curveReferences
Type: System.Collections.GenericIListReference
The references.

Return Value

True if the arguments passed the checks, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also