NewAreaBoundaryLine Method


Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
	SketchPlane sketchPlane,
	Curve geometryCurve,
	ViewPlan areaView
)
Visual Basic
Public Function NewAreaBoundaryLine ( _
	sketchPlane As SketchPlane, _
	geometryCurve As Curve, _
	areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
	SketchPlane^ sketchPlane, 
	Curve^ geometryCurve, 
	ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.DBSketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.DBCurve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.DBViewPlan
The View for the new Area

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the sketch plane does not exist in the given document.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the area view does not exist in the given document.

See Also