Document New |
Creates a new boundary line as an Area border.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ModelCurve NewAreaBoundaryLine(
SketchPlane sketchPlane,
Curve geometryCurve,
ViewPlan areaView
)
Parameters
- sketchPlane SketchPlane
- The sketch plane.
- geometryCurve Curve
- The geometry curve on which the boundary line are
- areaView ViewPlan
- The View for the new Area
Return Value
ModelCurve
Exception | Condition |
---|---|
ArgumentException | Thrown if the sketch plane does not exist in the given document. |
ArgumentException | Thrown if the area view does not exist in the given document. |