Prompts the end-user to control whether a type parameter contained in the specified table cell should be allowed edited.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- tableView
- Type: Autodesk.Revit.DBTableView
The table view.
- sectionType
- Type: Autodesk.Revit.DBSectionType
The section the row lies in.
- row
- Type: SystemInt32
The row index in the section.
- column
- Type: SystemInt32
The column index in the section.
Return Value
Returns true if editing the cell is allowed; otherwise false.Remarks
If the specified cell contains an instance parameter, the method automatically returns true without prompting the user. For type parameters, a task dialog will be shown and the user's choice will be returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration |