TestCellAndPromptToEditTypeParameter Method


Table View UIUtils Test Cell And Prompt To Edit Type Parameter Method

Prompts the end-user to control whether a type parameter contained in the specified table cell should be allowed edited.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool TestCellAndPromptToEditTypeParameter(
	TableView tableView,
	SectionType sectionType,
	int row,
	int column
)

Parameters

tableView TableView
The table view.
sectionType SectionType
The section the row lies in.
row Int32
The row index in the section.
column Int32
The column index in the section.

Return Value

Boolean
Returns true if editing the cell is allowed; otherwise false.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given row number row is invalid. -or- The given column number column is invalid. -or- A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the specified cell contains an instance parameter, the method automatically returns true without prompting the user. For type parameters, a task dialog will be shown and the user's choice will be returned.
See Also