IntersectionResult Class


This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public class IntersectionResult : APIObject
Visual Basic
Public Class IntersectionResult _
	Inherits APIObject
Visual C++
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBIntersectionResult

See Also