IntersectionResult Class


Intersection Result Class

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB IntersectionResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IntersectionResult : APIObject

The IntersectionResult type exposes the following members.

Constructors
Name Description
Public method IntersectionResult Initializes a new instance of the IntersectionResult class
Top
Properties
Name Description
Public property Distance Distance from the original object to located point.
Public property EdgeObject Edge of the face close to the point of intersection.
Public property EdgeParameter Parameter of a point on the edge closest to the point of intersection.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Parameter 1d parameter of the point of intersection.
Public property UVPoint 2d (or two 1d) parameters of the point of intersection.
Public property XYZPoint Point of intersection in local 3d coordinates.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also