IntersectionResult Class


Intersection Result Class

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB IntersectionResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IntersectionResult : APIObject

The IntersectionResult type exposes the following members.

Constructors
Name Description
Public method IntersectionResult Initializes a new instance of the IntersectionResult class
Top
Properties
Name Description
Public property Distance Distance from the original object to located point.
Public property EdgeObject Edge of the face close to the point of intersection.
Public property EdgeParameter Parameter of a point on the edge closest to the point of intersection.
Public property Parameter 1d parameter of the point of intersection.
Public property UVPoint 2d (or two 1d) parameters of the point of intersection.
Public property XYZPoint Point of intersection in local 3d coordinates.
Top
Methods
Name Description
Top
See Also