Removes the vertex corresponding to the specified index. Can not remove the start or end vertex if it already connects to other element.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: SystemInt32
The index which should be in [0, NumberOfVertices).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The index should be between 0 and the number of vertices of the wire. |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.ExceptionsInvalidOperationException | The wire has only 2 vertices, so one cannot be removed. -or- Can't remove the vertex when the vertex is start or end point and the wire connects to one element. |