RemoveVertex Method


Wire Remove Vertex Method

Removes the vertex corresponding to the specified index. Can not remove the start or end vertex if it already connects to other element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RemoveVertex(
	int index
)

Parameters

index Int32
The index which should be in [0, NumberOfVertices).
Exceptions
Exception Condition
ArgumentException The index should be between 0 and the number of vertices of the wire.
InvalidOperationException The wire has only 2 vertices, so one cannot be removed. -or- Can't remove the vertex when the vertex is start or end point and the wire connects to one element.
See Also