Show Method


Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public TaskDialogResult Show()
Visual Basic
Public Function Show As TaskDialogResult
Visual C++
public:
TaskDialogResult Show()

Return Value

The user's response to the task dialog.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when the task dialog is shown out of main thread of Revit or when an extra checkbox and a verification checkbox are enabled at the same time.

See Also