Show Method


Task Dialog Show Method

Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TaskDialogResult Show()

Return Value

TaskDialogResult
The user's response to the task dialog.
Exceptions
Exception Condition
InvalidOperationException Thrown when the task dialog is shown out of main thread of Revit or when an extra checkbox and a verification checkbox are enabled at the same time.
See Also