Flux Property


The flux intensity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public double Flux { get; set; }
Visual Basic
Public Property Flux As Double
	Get
	Set
Visual C++
public:
property double Flux {
	double get ();
	void set (double value);
}

Field Value

The flux value in lm as a numerical value between 0 and 1e+30.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The flux intensity value is not valid because it is not between 0 and 1e+30.

See Also