NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)


Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
	Face face,
	Line position,
	FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
	face As Face, _
	position As Line, _
	symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
	Face^ face, 
	Line^ position, 
	FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DBFace
A face of a geometry object.
position
Type: Autodesk.Revit.DBLine
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DBFamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also