NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)


Application New Family Instance Creation Data(Face, Line, Family Symbol) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
	Face face,
	Line position,
	FamilySymbol symbol
)

Parameters

face Face
A face of a geometry object.
position Line
A line on the face defining where the symbol is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

Return Value

FamilyInstanceCreationData
See Also