Creates a new ImageInstance element placed in a view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- view
- Type: Autodesk.Revit.DBView
The view in which the image will be placed.
- imageTypeId
- Type: Autodesk.Revit.DBElementId
The id of the ImageType element for this ImageInstance.
- placementOptions
- Type: Autodesk.Revit.DBImagePlacementOptions
Options that specify where the ImageInstance should be placed.
Return Value
The new ImageInstance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given view cannot contain ImageInstance elements -or- The given imageTypeId can not be used as a ImageType for ImageInstance elements -or- The given placementOptions specify a location that is more than 10 miles from the origin of the model. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |