Image |
Creates a new ImageInstance element placed in a view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ImageInstance Create(
Document document,
View view,
ElementId imageTypeId,
ImagePlacementOptions placementOptions
)
Parameters
- document Document
- The document.
- view View
- The view in which the image will be placed.
- imageTypeId ElementId
- The id of the ImageType element for this ImageInstance.
- placementOptions ImagePlacementOptions
- Options that specify where the ImageInstance should be placed.
Return Value
ImageInstanceThe new ImageInstance.

Exception | Condition |
---|---|
ArgumentException | The given view cannot contain ImageInstance elements -or- The given imageTypeId can not be used as a ImageType for ImageInstance elements -or- The given placementOptions specify a location that is more than 10 miles from the origin of the model. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |