RevitCommandId Class


Represents a command id in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public class RevitCommandId : IDisposable
Visual Basic
Public Class RevitCommandId _
	Implements IDisposable
Visual C++
public ref class RevitCommandId : IDisposable

Remarks

Each Revit command is assigned a command id and non-localized name. This class allows you to look up a command by its name, and represents any Revit command in the use of an AddInCommandBinding.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.UIRevitCommandId

See Also