Revit |
Represents a command id in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The RevitCommandId type exposes the following members.

Name | Description | |
---|---|---|
![]() | CanHaveBinding | Indicates whether the command can be assigned a binding to an external add-in. |
![]() | HasBinding | Indicates whether a replacement of either the Execute or CanExecute events (or both) have been applied to this command. |
![]() | Id | The command id. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Name | The command name. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RevitCommandId |
![]() ![]() | LookupCommandId | Looks up and retrieves the Revit command id with the given id string. |
![]() ![]() | LookupPostableCommandId | Looks up and retrieves the Revit command id with the given id string. |

Each Revit command is assigned a command id and non-localized name. This class allows you to look up a command by its name, and represents any Revit command in the use of an AddInCommandBinding.