CheckBuildingEnvelope Method


Checks that the building envelope determination method falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool CheckBuildingEnvelope(
	gbXMLExportBuildingEnvelope determinationMethod
)
Visual Basic
Public Shared Function CheckBuildingEnvelope ( _
	determinationMethod As gbXMLExportBuildingEnvelope _
) As Boolean
Visual C++
public:
static bool CheckBuildingEnvelope(
	gbXMLExportBuildingEnvelope determinationMethod
)

Parameters

determinationMethod
Type: Autodesk.Revit.DB.AnalysisgbXMLExportBuildingEnvelope
The building envelope determination method to be checked.

Return Value

True if the building envelope determination method falls within an appropriate range, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also