CheckBuildingEnvelope Method


Energy Data Settings Check Building Envelope Method

Checks that the building envelope determination method falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CheckBuildingEnvelope(
	gbXMLExportBuildingEnvelope determinationMethod
)

Parameters

determinationMethod gbXMLExportBuildingEnvelope
The building envelope determination method to be checked.

Return Value

Boolean
True if the building envelope determination method falls within an appropriate range, false otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also