RemoveDistributionSysType Method


Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveDistributionSysType(
	DistributionSysType distributionSysType
)
Visual Basic
Public Sub RemoveDistributionSysType ( _
	distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
	DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
Type: Autodesk.Revit.DB.ElectricalDistributionSysType

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also