SetLightDimmer Method


Sets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetLightDimmer(
	ElementId viewId,
	ElementId lightId,
	double dimmingValue
)
Visual Basic
Public Sub SetLightDimmer ( _
	viewId As ElementId, _
	lightId As ElementId, _
	dimmingValue As Double _
)
Visual C++
public:
void SetLightDimmer(
	ElementId^ viewId, 
	ElementId^ lightId, 
	double dimmingValue
)

Parameters

viewId
Type: Autodesk.Revit.DBElementId
The Id of the view
lightId
Type: Autodesk.Revit.DBElementId
The Id of the light to turn on or off
dimmingValue
Type: SystemDouble
The dimmer value to set int the range of [0.0, 1.0]

Remarks

The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance -or- The given dimming value is not in the range [0.0, 1.0]
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also