SetLightDimmer Method


Light Group Manager Set Light Dimmer Method

Sets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLightDimmer(
	ElementId viewId,
	ElementId lightId,
	double dimmingValue
)

Parameters

viewId ElementId
The Id of the view
lightId ElementId
The Id of the light to turn on or off
dimmingValue Double
The dimmer value to set int the range of [0.0, 1.0]
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance -or- The given dimming value is not in the range [0.0, 1.0]
ArgumentNullException A non-optional argument was null
Remarks
The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on
See Also