NewPointRelativeToPoint Method


Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public PointRelativeToPoint NewPointRelativeToPoint(
	Reference hostPointReference
)
Visual Basic
Public Function NewPointRelativeToPoint ( _
	hostPointReference As Reference _
) As PointRelativeToPoint
Visual C++
public:
PointRelativeToPoint^ NewPointRelativeToPoint(
	Reference^ hostPointReference
)

Parameters

hostPointReference
Type: Autodesk.Revit.DBReference
The reference of the host point.

Return Value

If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument hostPointReference is a null reference (Nothing in Visual Basic).

See Also